> Conda Channel is Unavailable

Hello, I'm trying to create a Python environment using the environment.yml provided in the github repo. When I run conda env create -f environment.yml, I get an error stating the channel is unavailable:

UnavailableInvalidChannel: HTTP 404 NOT FOUND for channel <https://repo.anaconda.com>

The channel is not accessible or is invalid.

You will need to adjust your conda configuration to proceed.
Use `conda config --show channels` to view your configuration's current state,
and use `conda config --show-sources` to view config file locations.

Any ideas on how to fix this? Thanks.

Posted by: james.maher @ Jan. 7, 2023, 3:56 p.m.

Hi James, maybe try the step on this page: https://docs.anaconda.com/anaconda-professional/troubleshooting/#error
Let us know how that goes. Apologies for the late reply!

Posted by: ccafeccafe @ Jan. 11, 2023, 12:50 p.m.

I think I figured out the issue. I had an old version of Anaconda and it will pulling from a channel that did not exist. Uninstalling the old version and installing the new version seems to have fixed it.

Posted by: james.maher @ Jan. 12, 2023, 6:08 p.m.

Great to hear you were able to solve your issue James. Thanks for letting us know what the problem was and how you fixed it.

Posted by: adelanovic @ Jan. 18, 2023, 1:53 p.m.
Post in this thread